Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70240 Skopiuj do schowka Dni tygodnia - własne nazwy
Autor Wiadomość
DarcioR
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 49
Wysłany: 25-02-2021, 14:24   Dni tygodnia - własne nazwy

Reprezentacją daty np. 2021-02-25 może być w innej komórce dzień tygodnia przypisany tej dacie - tutaj czwartek . Jak w prosty sposób wprowadzić własne ( dowolne nazwy ) dni tygodnia - chodzi oczywiście o inny - własny skrót tej nazwy . Np Poni ; Wtor ; Środ ; Czwa ; Piąt ; Sobo ; Nied ; . W przykładzie są to przypadkowo pierwsze cztery litery z nazwy tygodnia - ale nie może być to zasadą na której będzie się opierać formuła .
Z góry dziękuję za pomoc
_________________
DarcioR
ID posta: 400991 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2770 razy
Posty: 4642
Wysłany: 25-02-2021, 14:39   

np. taki
Kod:
=WYSZUKAJ(DZIEŃ.TYG(A1;2);{1\"Poni";2\"Wtor";3\"Środ";4\"Czwa";5\"Piąt";6\"Sobo";7\"Nied"})
_________________
Pozdrawiam
Asia
ID posta: 400992 Skopiuj do schowka
 
 
bodek 


Wersja: Win Office 2019
Pomógł: 994 razy
Posty: 2900
Wysłany: 25-02-2021, 14:41   

Na przykład na sztywno w formule
Kod:
=INDEKS({"Niedz";"Poni";"Wtor";"smsmms";"CzwAR";"PTK…";"kokoko"};DZIEŃ.TYG(C45))
lub z odwołaniem do komórek
Kod:
=INDEKS($A$1:$A$7;DZIEŃ.TYG(C1))
_________________
Szkolenia z Excela, Power Query, Power Pivot, wizualizacje danych w Excelu, szkolenia online
ID posta: 400993 Skopiuj do schowka
 
 
DarcioR
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 49
Wysłany: 25-02-2021, 14:47   

Super wszystko działa - dziękuję za pomoc
_________________
DarcioR
ID posta: 400994 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 208 razy
Posty: 714
Wysłany: 25-02-2021, 15:01   

Formula
Kod:
=WYBIERZ(DZIEŃ.TYG(A1;2);"Poni";"Wtor";"Środ";"Czwa";"Piąt";"Sobo";"Nied")
ID posta: 400997 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe