Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64410 Skopiuj do schowka czy zawiera się między datami i puste komórki
Autor Wiadomość
zabka_m 
świeżak


Wersja: Win Office 2007
Posty: 3
Wysłany: 13-03-2019, 10:37   czy zawiera się między datami i puste komórki

mam podane daty w kolumnie A, B
A - data rozpoczęcia
B- data zakończenia

w kolumnach D -O potrzebuję wstawić wartości w zależności czy dana data z danej kolumny zawiera się w datach od do z kolumn A, B

jeżeli brak danych w kolumnie A, B - trzeba uznać żeby dane przypisać,
może być brak daty pocz, końcowej lub obydwu

załącznik dla lepszego zobrazowania

zadane.xlsx
Pobierz Plik ściągnięto 12 raz(y) 8.49 KB

ID posta: 364089 Skopiuj do schowka
 
 
jkb1906 
Exceloholic


Wersja: Win Office 365
Pomógł: 40 razy
Posty: 159
Wysłany: 13-03-2019, 10:46   

W sensie, że tylko wariant z uzupełnioną datą od i datą do ma skutkować zaczytaniem danych?
Spróbuj w D2 wstawić poniższe i przeciągnąć w dół i w prawo o zakres Twojej tabeli:
Kod:
=JEŻELI(ORAZ(D$1>=$A2;D$1<=$B2);D$7;"")
ID posta: 364092 Skopiuj do schowka
 
 
zabka_m 
świeżak


Wersja: Win Office 2007
Posty: 3
Wysłany: 13-03-2019, 10:57   

właśnie nie tylko z uzupełnioną , jeżeli puste komórki to również mają być uzupełnione dane,
może być tylko data pocz, albo tylko końcowa, albo obydwie, lub też obie puste -( jak puste to bez ograniczeń.)
ID posta: 364097 Skopiuj do schowka
 
 
jkb1906 
Exceloholic


Wersja: Win Office 365
Pomógł: 40 razy
Posty: 159
Wysłany: 13-03-2019, 11:31   

Ok, w takim razie ta formuła powinna załatwić sprawę:
Kod:
=JEŻELI(ORAZ($A2="";$B2="");D$7;JEŻELI(ORAZ($A2<>"";$B2="");JEŻELI(D$1>=$A2;D$7;"");JEŻELI(ORAZ(D$1>=$A2;D$1<=$B2);D$7;"")))

Zobacz w załączniku.

zadane2.xlsx
Pobierz Plik ściągnięto 12 raz(y) 10.57 KB

ID posta: 364104 Skopiuj do schowka
 
 
zabka_m 
świeżak


Wersja: Win Office 2007
Posty: 3
Wysłany: 13-03-2019, 11:49   

super, działa.
dzięki
ID posta: 364105 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe