Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64424 Skopiuj do schowka automatyczne zwracanie wartości z listy + kilka problemów
Autor Wiadomość
uve 
Starszy Forumowicz


Posty: 47
Wysłany: 14-03-2019, 00:42   automatyczne zwracanie wartości z listy + kilka problemów

Cześć.
Zabrakło mi umiejętności, więc zwracam się o pomoc. Plik z przykładowymi danymi w załączniku. Ogólnie plik pokazuje wydajność produkcji w ciągu miesiąca na trzech zmianach produkcyjnych.

Poniżej opisane to czego nie umiem zrobić:
1a) Zamysł jest taki, że dane mają się zaciągać z zakładki "Lista pracochłonności" do zakładki " zestawienie wydajności" do kolumny G w zależności od tego jaki to materiał (stal czarna, stal nierdzewna, mosiądz) oraz od grupy, materiału i produktu - nagłówki/komórki oznaczyłem takimi samymi kolorami w obu zakładkach. Dane miałyby się zaciągać do kolumny G, wpisałem kilka adresów dla pokazania co miałaby pokazać formuła.

1b) Alternatywnie do rozwiązania1a, ale może się okazać "w praniu", że to będzie lepsze. Efekt taki sam jak w 1a, ale chciałbym pominąć kolumnę B w zakładce "Lista pracochłonności" i jednocześnie kolumnę C w " zestawienie wydajności". Zamiast tego chciałbym się oprzeć na tekście w kolumnie E zakładki "zestawienie wydajności" gdzie formuła przeszukiwałaby kolumnę C zakładki "Lista pracochłonności" czy występuje tam taki fragment tekstu i zwracała wartość do kolumny G czyli tak jak w 1a.

2) Kolejny problem mam w kolumnach I i J w zakładce "zestawienie wydajności". Chciałbym, żeby wyliczone tam już % i liczby pokazywały się tylko w pierwszym wierszu zmiany I, II i III w danym dniu. Liczba wierszy dla dnia i zmian będzie zmienna.

z góry dzięki za pomoc :-)

Rejest wydajności.xlsx
Pobierz Plik ściągnięto 9 raz(y) 103.76 KB

ID posta: 364177 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2352 razy
Posty: 3997
Wysłany: 14-03-2019, 07:45   

1a)
Kod:
=SUMA.ILOCZYNÓW(('Lista pracochłonności'!B$3:B$34=C3)*('Lista pracochłonności'!C$3:C$34=E3)*('Lista pracochłonności'!D$2:F$2=D3)*'Lista pracochłonności'!D$3:F$34)

1b)
Kod:
=SUMA.ILOCZYNÓW(('Lista pracochłonności'!C$3:C$34=E3)*('Lista pracochłonności'!D$2:F$2=D3)*'Lista pracochłonności'!D$3:F$34)

2)
I3
Kod:
=JEŻELI(SUMA.ILOCZYNÓW((A$3:A3=A3)*(B$3:B3=B3))=1;JEŻELI.BŁĄD(SUMA.WARUNKÓW($F$3:$F$1993;$A$3:$A$1993;$A3;$B$3:$B$1993;$B3)/SUMA.WARUNKÓW($G$3:$G$1993;$A$3:$A$1993;$A3;$B$3:$B$1993;$B3);"");"")

J3
Kod:
=JEŻELI(SUMA.ILOCZYNÓW((A$3:A3=A3)*(B$3:B3=B3))=1;JEŻELI(A3<>"";SUMA.WARUNKÓW($F$3:$F$1993;$A$3:$A$1993;$A3;$B$3:$B$1993;$B3);"");"")
_________________
Pozdrawiam
Asia
ID posta: 364185 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe