Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63599 Skopiuj do schowka zliczanie trzech wierszy przy użyciu filtrów
Autor Wiadomość
uczeń85 
świeżak


Posty: 7
Wysłany: 27-12-2018, 19:37   zliczanie trzech wierszy przy użyciu filtrów

witam.
czy istnieje możliwość zliczania danych po wcześniejszym zastosowaniu filtrów? wg kryteriów, by liczyło po trzy pola w kolejnym wierszu.
w kolumnie A mamy podane kraje, do każdego jest wpisana liczba w kolumnie B. będę chciał zliczać po trzy pola i wynik zapisywać w kolumnie C. Stosujemy filtr w kolumnie A.

w tym wypadku chce zliczać ilość po zastosowaniu filtru Polska.

w odpowiedzi chce sumować trzy ostatnie pola z kolumny B przy zastosowaniu filtru. czyli na początku zliczamy 3 pola (pierwsze, drugie, trzecie). Następnie automatycznie kolejne wiersze (czyli drugie/trzecie/czwarte itd)

Dla dokładnego zrozumienia podaje jakie chce otrzymać wyniki
c7=27, ponieważ B2+B3+B7 = 1 + 14 +12 = 27
c12=40, ponieważ B3+B7+B12= 14 +12 + 14 = 40
c13=28, ponieważ B7+B12+B13=12 + 14 + 2 = 28
c18=26, ponieważ B12+B13+B18=14 + 2 + 10= 26

jeżeli będę stosował sumy.częściowe (109, dane tylko aktywne) to muszę za każdym razem zaznaczyć osobno trzy pola które zliczam. mi chodzi aby zastosować to przy dużej ilości danych, więc ręczne zaznaczanie trzech pól odpada, a potrzebuje automatycznie przesunąć formułę, by samo zliczało.

czy jest to możliwe?

dane.xlsx
Pobierz Plik ściągnięto 25 raz(y) 8.54 KB

ID posta: 359133 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Pomógł: 258 razy
Posty: 1395
Wysłany: 28-12-2018, 10:01   

Na formułach się nie podejmuje. Rozwiązanie VBA w zał.

Info:
1. kolumna D (ilość danych krajów od A4 do aktualnego wiersza) służyła mi do pomocy - możesz wywalić linię
Kod:
Cells(i, 4).Value = k
z kodu.

2. Wartości zadeklarowałem jako liczby całkowite. Jeśli mogą być innego typu - zmień na odpowiedni
Kod:
Dim x1 As Integer, x2 As Integer


Kopia dane.xlsm
Pobierz Plik ściągnięto 8 raz(y) 20.88 KB

_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 359153 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 3
Wersja: Win Office 2016
Pomógł: 3712 razy
Posty: 7397
Wysłany: 28-12-2018, 11:19   

Jeśli jesteś skłonny pogodzić się z obecnością (może być ukryta) kolumny pomocniczej, to takie rozwiązanie formułami:

W D2 (czy w innej kolumnie - to ta nasza pomocnicza):
Kod:
=JEŻELI(SUMY.CZĘŚCIOWE(102;B2);MAX(D$1:D1)+1;"")
i kopia w dół.
I wtedy w C2 (i kopia w dół):
Kod:
=SUMA.WARUNKÓW(B:B;D:D;">=" &D2;D:D;"<=" &D2+2)


Zeszyt2.xlsx
Pobierz Plik ściągnięto 15 raz(y) 10.73 KB

_________________
Kaper Jej Królewskiej Mości :boss

Jestem leniwy, ale się staram
ID posta: 359159 Skopiuj do schowka
 
 
uczeń85 
świeżak


Posty: 7
Wysłany: 03-01-2019, 12:34   

dziękuję Wam za pomoc.
raczej nie tworzyłem nic w VBA, więc wykorzystałem pomoc z formułami
ID posta: 359551 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe