Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Zbiniek
28-01-2019, 13:50
wyszukiwanie w wierszu i wynik z następnej komórki
Autor Wiadomość
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 27-01-2019, 21:48   wyszukiwanie w wierszu i wynik z następnej komórki

mam dwa problemy do rozwiązania, może ktoś mógłby pomóc z formułą.
1.
szukam formuły, aby w wierszu znalazł komórkę z tekstem TAK i wypisał co jest w komórce zaraz za nią, np w zakresie A1:Z1 znajduje TAK w K1 ale wypisuje mi co jest w L1.

2.
szukam formuł, aby w kolumnie A znalazł powiedzmy 2 największe wartości i wpisał co znajduje się w komórce obok z kolumny B.
np. w zakresie A1:A10 największe dwie wartości to: 20 w A3 i 20 w A5, więc formuły powinny wypisać wartości z B3 i B5

edycja Zbiniek:
Szanuj innych użytkowników (szczególnie tych, od których oczekujesz pomocy) i stosuj zasady poprawnej pisowni.
P.S. Chyba każda przeglądarka internetowa ma funkcję sprawdzania pisowni, więc z niej korzystaj.
POPRAWIŁEM ZA CIEBIE..
ID posta: 361424 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1538 razy
Posty: 4868
Wysłany: 28-01-2019, 08:52   

W załączniku w żółtych komórkach masz formuły.

Maksymalne.xlsx
Pobierz Plik ściągnięto 22 raz(y) 8.21 KB

ID posta: 361437 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 28-01-2019, 17:29   

dzięki pierwszy problem rozwiązany, natomiast drugi jeszcze nie, może źle się wyraziłem w pytaniu, nie chodzi, aby wypisał wyniku w tym samym wierszu a w konkretnych komórkach np. e2 i e3. ogólnie to załączam plik zobacz z czym mam problem, w moich formułach

Maksymalne.xlsx
Pobierz Plik ściągnięto 16 raz(y) 9.03 KB

ID posta: 361467 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2393 razy
Posty: 4064
Wysłany: 28-01-2019, 18:39   

w E2
Kod:
=JEŻELI(D2="";"";INDEKS(B$2:B$10;PODAJ.POZYCJĘ(1;INDEKS((A$2:A$10=D2)*(LICZ.JEŻELI(E$1:E1;$B$2:$B$10)=0);0);0)))

i kopia w dół
_________________
Pozdrawiam
Asia
ID posta: 361473 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 29-01-2019, 19:51   

dzięki Asia działa :)
ID posta: 361541 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 30-01-2019, 18:11   

jeszcze jedna proźba odnośnie zadania 1.
Tadek podał formułe która działa świetnie:
=INDEKS(A1:Z1;1;PODAJ.POZYCJĘ("TAK";A1:Z1;0)+1)
jak zmienić tą formułę aby w przypadku gdy jest kilka komórek z "TAK"
a. zwracał nie pierwszą a ostatnie dopasowanie (najważniejsze)
b. zwracał nie pierwsze a np. drugie dopasowanie
c. zwracał nie pierwsze a np. przedostatnie dopasowanie
ID posta: 361596 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1538 razy
Posty: 4868
Wysłany: 31-01-2019, 07:36   

Trochę to niejasne.
Pokaż na przykładzie o co chodzi.
Wypełnij te 3 przypadki "z palca".
ID posta: 361625 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 31-01-2019, 08:14   

dobrze załączam plik

Maksymalne.xlsx
Pobierz Plik ściągnięto 19 raz(y) 8.79 KB

ID posta: 361628 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2393 razy
Posty: 4064
Wysłany: 31-01-2019, 09:33   

tablicowe (należy zatwierdzić klawiszami Ctrl+Shift+Enter)
w K4
Kod:
=INDEKS(A1:Z1;MAX.K(JEŻELI(A1:Z1="TAK";NR.KOLUMNY(A1:Z1);"");1)+1)

w K5
Kod:
=INDEKS(A1:Z1;MIN.K(JEŻELI(A1:Z1="TAK";NR.KOLUMNY(A1:Z1);"");2)+1)

w K6
Kod:
=INDEKS(A1:Z1;MIN.K(JEŻELI(A1:Z1="TAK";NR.KOLUMNY(A1:Z1);"");LICZ.JEŻELI(A1:Z1;"TAK")-1)+1)
_________________
Pozdrawiam
Asia
ID posta: 361635 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1538 razy
Posty: 4868
Wysłany: 31-01-2019, 11:58   

Można również makrem.
Kliknij w załączniku "Pobierz".

Maksymalne kopia.xlsm
Pobierz Plik ściągnięto 15 raz(y) 15.33 KB

ID posta: 361652 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 31-01-2019, 19:40   

dziękuje pięknie
ID posta: 361682 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 05-02-2019, 23:20   

Mam jeszcze jeden problem tym razem chcialbym aby wypisal mi nie komorke obok a komorke z tej samej kolumny a w innym wierszu, zalanczam plik może Asia uda ci się z tym zadaniem?

Maksymalne.xlsx
Pobierz Plik ściągnięto 16 raz(y) 10.51 KB

ID posta: 362039 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2393 razy
Posty: 4064
Wysłany: 06-02-2019, 08:20   

załącznik

Maksymalne (3).xlsx
Pobierz Plik ściągnięto 19 raz(y) 10.69 KB

_________________
Pozdrawiam
Asia
ID posta: 362052 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 41
Wysłany: 07-02-2019, 00:23   

wielkie dzieki za te formuły,
natomiast w tym ostatnim zadaniu chodzi mi o coś innego. Chciałbym aby formuła znalazła ostatnią parę w wierszu (TAK i niebieski) i wypisała date z wiersza 2. czyli w tym przypadku ostatnia para TAK I NIEBIESKI TO M5 i M6 więc formuła powinna zwrócić datę 19-02-13, czy dasz radę napisać taką formułe ?

Maksymalne (3).xlsx
Pobierz Plik ściągnięto 18 raz(y) 11.08 KB

ID posta: 362103 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2393 razy
Posty: 4064
Wysłany: 07-02-2019, 07:09   

dałam radę ;-)
Kod:
=INDEKS(A2:O2;PODAJ.POZYCJĘ(2;INDEKS(1/(A5:O5="TAK")/(B5:P5="niebieski");0);1))
_________________
Pozdrawiam
Asia
Ostatnio zmieniony przez Asia_@. 07-02-2019, 08:35, w całości zmieniany 1 raz  
ID posta: 362108 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe