Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Zbiniek
28-01-2019, 13:50
wyszukiwanie w wierszu i wynik z następnej komórki
Autor Wiadomość
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4264
Wysłany: 07-02-2019, 08:34   

ezq napisał/a:
wielkie dzieki za te formuły,
natomiast w tym ostatnim zadaniu chodzi mi o coś innego. Chciałbym aby formuła znalazła ostatnią parę w wierszu (TAK i niebieski) i wypisała date z wiersza 2. czyli w tym przypadku ostatnia para TAK I NIEBIESKI TO M5 i M6 więc formuła powinna zwrócić datę 19-02-13, czy dasz radę napisać taką formułe ?

Chyba chodzi o M5 i N5.

Skoro z jednym warunkiem "TAK" masz już
Kod:

=WYSZUKAJ(2;1/(A5:P5="TAK");A2:P2)


to dodając warunek drugi, trzeci, czwarty itd. dodajesz kolejne /(...). Czyli w tym przypadku formuła
Kod:

=WYSZUKAJ(2;1/(A5:P5="TAK")/(B5:Q5="niebieski");A2:P2)


Dodane jest /(B5:Q5="niebieski") dla drugiego warunku.
ID posta: 362113 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 40
Wysłany: 08-02-2019, 00:31   

dzięki obie formuły działają :)
niestety znalazłem mały problemik w zadaniu 1. , w przypadku gdy formuła znajduje ostatnie dopasowanie "TAK" I wypisuje co jest w komórce obok czyli w tym przypadku powinno zwrócić "bordowy" działa tylko gdy zakres jest od A1, jak zmienie np. Na zakres zaczynający się od E2 to zwraca 0 , jak to rozwiązać?
to działa :
Kod:
=INDEKS(A5:W5;MAX.K(JEŻELI(A5:W5="TAK";NR.KOLUMNY(A5:W5);"");1)+1)

a to już zwraca 0
Kod:
=INDEKS(E5:W5;MAX.K(JEŻELI(E5:W5="TAK";NR.KOLUMNY(E5:W5);"");1)+1)


Maksymalne (3).xlsx
Pobierz Plik ściągnięto 14 raz(y) 11.38 KB

ID posta: 362182 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4264
Wysłany: 08-02-2019, 01:05   

ezq napisał/a:

to działa :
Kod:
=INDEKS(A5:W5;MAX.K(JEŻELI(A5:W5="TAK";NR.KOLUMNY(A5:W5);"");1)+1)

a to już zwraca 0
Kod:
=INDEKS(E5:W5;MAX.K(JEŻELI(E5:W5="TAK";NR.KOLUMNY(E5:W5);"");1)+1)

Ktoś podał formułę w takiej postaci, że jak zmienisz zakres to nie wiesz, co trzeba zmienić.

Niech formuła jest w takiej postaci
Kod:

=INDEKS(A5:W5;MAX.K(JEŻELI(A5:W5="TAK";NR.KOLUMNY(A5:W5)-NR.KOLUMNY(A5)+1;"");1)+1)


No to po zmianie zakresu na E5:W5
Kod:

=INDEKS(E5:W5;MAX.K(JEŻELI(E5:W5="TAK";NR.KOLUMNY(E5:W5)-NR.KOLUMNY(E5)+1;"");1)+1)

-------------
Ale formuła normalna z WYSZUKAJ jest prostsza

Kod:

=WYSZUKAJ(2;1/(A5:W5="TAK");B5:X5)


a po zmianie zakres na E5:W5

Kod:

=WYSZUKAJ(2;1/(E5:W5="TAK");F5:X5)
ID posta: 362183 Skopiuj do schowka
 
 
ezq
Starszy Forumowicz


Posty: 40
Wysłany: 09-02-2019, 13:28   

dziękuje
ID posta: 362260 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe