Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 67608 Skopiuj do schowka Sumowanie wystąpień osoby w wierszu (w komórce różne dane)
Autor Wiadomość
maciek_m 
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 41
Wysłany: 21-03-2020, 22:10   Sumowanie wystąpień osoby w wierszu (w komórce różne dane)

Potrzebuję zsumować ile razy występuje dana osoba w wierszu w tabeli. Obok każdego nazwiska znajduje się jakaś liczba, którą pomijamy, czasem gdy w komórce jest tylko liczba to dodajemy osobę z lewej strony komórki. Gdy jest jest kilka liczb obok siebie to dodajemy jak wyżej, każdą liczbę traktujemy jak osobę występująca najbliżej z lewej strony. Przykład w załączniku, pokolorowałem osoby by łatwiej zrozumieć o co mi chodzi.

Przykład liczenie osób.xlsx
Pobierz Plik ściągnięto 10 raz(y) 10.5 KB

ID posta: 384072 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 336 razy
Posty: 1050
Wysłany: 21-03-2020, 22:42   

Z komórkami pomocniczymi.

Kopia Przykład liczenie osób.xlsx
Pobierz Plik ściągnięto 13 raz(y) 13.63 KB

_________________
Pozdrawiam
xFish
ID posta: 384075 Skopiuj do schowka
 
 
Tadek
Excel Expert


Wersja: Win Office 2007
Pomógł: 1801 razy
Posty: 5345
Wysłany: 22-03-2020, 08:40   

Bez pomocniczych:
W J3 wstaw formułę:
Kod:
=JEŻELI(LICZ.JEŻELI($B3:$H3;J$2&"*")=0;"";LICZ.JEŻELI($B3:$H3;J$2&"*"))
i skopiuj w dół i w prawo.
ID posta: 384082 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe