Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68577 Skopiuj do schowka Sumowanie czasu
Autor Wiadomość
EmmaCarmen
świeżak


Wersja: Win Office 2007
Posty: 1
Wysłany: 23-07-2020, 16:54   Sumowanie czasu

Witam wszystkich! Bardzo proszę o pomoc w stworzeniu formuły, która sumowała by wyniki. W pierwszej kolumnie mam imię i nazwisko. W drugiej pojawiają się dane czasowe. Pan Kowalski robi pierwszy wiersz 2h, w drugim wierszu ma 4h, w trzecim 1 h. W kolejnej kolumnie potrzebuje aby wyniki sumowały się od pierwszego wiersza. Czyli kolumna C1 =suma B1; C2= suma B1:b2; C3= suma b1:b3 itd.
Problem mam jednak z tym ze w kolumnie A mam różne nazwiska. Potrzebuje funkcji logicznej która odróżni ze np w a15 zmieniło się nazwisko i zacznie sumować w kolumnie c od wiersza b15.
Mam nadzieje ze opisałam dobrze problem. Załączam tez plik przykładowy. Ktoś coś? Bardzo proszę o pomoc! Dzięki!!

edycja Zbiniek:
Stary tytuł: "Potrzebna pomoc z formułą"
Zmieniłem temat wątku, tak by odzwierciedlał sedno problemu (zgodnie z pkt. 1.4 Regulaminu naszego forum). Temat, który jest streszczeniem problemu, ułatwi innym użytkownikom w przyszłości odszukać podobny problem i wykorzystać z niego ewentualne rozwiązania.


przyklad.xlsx
Pobierz Plik ściągnięto 13 raz(y) 8.84 KB

ID posta: 390068 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2720 razy
Posty: 4569
Wysłany: 23-07-2020, 17:42   

Kod:
=SUMA.JEŻELI(A$2:A2;A2;B$2:B2)

i kopia w dół
_________________
Pozdrawiam
Asia
ID posta: 390071 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe