Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64099 Skopiuj do schowka Suma.Jeżeli z wykorzystaniem przesunięcia lub indeksu
Autor Wiadomość
ceadmyrkivid 
forumowicz


Posty: 17
Wysłany: 11-02-2019, 17:02   Suma.Jeżeli z wykorzystaniem przesunięcia lub indeksu

Cześć,
Proszę o pomoc w znalezieniu odpowiedniej formuły ułatwiającej sumowanie danych.
Arkusz będzie używany w google drive, dlatego makro nie będzie dla mnie korzystnym rozwiązaniem.
Dziękuję za wszelkie sugestię.

Opis:
Sumuje dane z wybranej tabeli B13-C27 z dn. 01/02/2019. za pomocą funkcji 'suma.jeżeli' następnie chciałbym użyć funkcji która pozwoliła by mi wyszukać z tabeli obok, również za pomocą 'suma.jeżeli' ale z użyciem funkcji np: przesunięcie lub indeks.
Czy istnieje funkcja pozwalająca na przesunięciu szukanych danych w tabeli?
Szukamy danych z tabeli H13-I27 oraz N13-O27.

Dziękuję za pomoc.

TRP 2019a.xlsx
Pobierz Plik ściągnięto 5 raz(y) 15.78 KB

  
ID posta: 362365 Skopiuj do schowka
 
 
Mentor82 
świeżak


Pomógł: 2 razy
Posty: 8
Wysłany: 11-02-2019, 17:18   

Cześć,
Trochę za mało informacji podałeś. Rozumie, że chcesz obliczyć dodatkowo sumę z innych tabel z użyciem suma.jeżeli tylko nie bardzo wiem czy funkcja ma zsumować znalezione wartośći w H13-I27 oraz N13-O27 czy tylko podać sumę albo z jednej albo z drugiej. Jezeli ma zsumować z obu to proponuję uzyć prostą formułę bez przesunięć tj =suma.jezeli.... dla pierwszej tabeli + suma.jezeli....dla drugiej tabeli.
_________________
Pozdrawiam,
Seba

"Giva a man a fish and you feed him for a day. Teach a man to fish and you feed him for a lifetime."
ID posta: 362366 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2326 razy
Posty: 3965
Wysłany: 11-02-2019, 17:38   

w B2
Kod:
=SUMA.JEŻELI(PRZESUNIĘCIE($B$13;;PODAJ.POZYCJĘ(B$1;$B$11:$O$11;0)-1;15);$A2;PRZESUNIĘCIE($B$13;;PODAJ.POZYCJĘ(B$1;$B$11:$O$11;0);15))

i kopia w prawo i w dół
_________________
Pozdrawiam
Asia
ID posta: 362368 Skopiuj do schowka
 
 
ceadmyrkivid 
forumowicz


Posty: 17
Wysłany: 11-02-2019, 18:17   

Dziękuję.
Właśnie o takie rozwiązanie chodziło.
Miłego dnia. :)

edycja Zbiniek:
Nie cytuj całej wypowiedzi znajdującej się bezpośrednio powyżej – w takim przypadku wiadomo, że się do niej odnosisz. Cytowanie stosuj tylko wtedy, gdy nawiązujesz do wypowiedzi o kilka postów wcześniej lub gdy komentujesz tylko jakiś fragment ostatniej wypowiedzi. W obu przypadkach zacytuj tylko fragment, do którego się odnosisz.
  
ID posta: 362369 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1141 razy
Posty: 3443
Wysłany: 12-02-2019, 00:19   

U mnie bez funkcji ulotnej 'PRZESUNIĘCIE'
Kod:
=SUMA.ILOCZYNÓW((INDEKS($A$13:$BZ$30;;PODAJ.POZYCJĘ(B$1;$11:$11;0))=$A2)*INDEKS($A$13:$BZ$30;;PODAJ.POZYCJĘ(B$1;$11:$11;0)+1))
Pozdrawiam.
ID posta: 362397 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe