Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63838 Skopiuj do schowka Problem: Jak policzyć "przedostatnią" wypełnioną k
Autor Wiadomość
apollo
ExcelSpec


Pomógł: 1236 razy
Posty: 4306
Wysłany: 28-01-2019, 09:52   

g3m napisał/a:

Może jeszcze spróbuję gdzieś z funkcjami, ale wspominałeś, że ciężko to objąć funkcją.

Spróbuj tak:
formuła dla D3
Kod:

=JEŻELI(C3="";"";JEŻELI(C3<JEŻELI.BŁĄD(WYSZUKAJ(10^6;C$2:C2);10^6);0;C3-WYSZUKAJ(10^6;C$2:C2)))

-> wybierz D3 -> Ctrl + C -> wybierz F3 -> Ctrl + V -> wybierz H3 -> Ctrl + V -> wybierz J3 -> Ctrl + V -> ESC (wychodzić z trybu kopiowania) -> kopiuj D3, F3, H3, J3 w dół
ID posta: 361441 Skopiuj do schowka
 
 
g3m
Starszy Forumowicz


Posty: 33
Wysłany: 31-01-2019, 18:45   

Apollo - właśnie testuję Twój kod. Wszystko wskazuje na to, że działa prawidłowo. Wydawało mi się, że ewentualne rozwiązanie będzie zawierało dość długi kod. Ale jak widać, zamknąłeś problem (temat) dość szybko i krótko - czego się nie spodziewałem.
Apollo, dzięki za Twój wkład. Mamy teraz rozwiązanie w dwóch formach (o ile makro to dla mnie czarna magia, to w tablicowej będę przynajmniej próbował rozłożyć i To rozpoznać..), no i przerzucę to też na androida. W następnym poście, po pełnym teście, zamknę temat.
Pozdrawiam.
ID posta: 361677 Skopiuj do schowka
 
 
g3m
Starszy Forumowicz


Posty: 33
Wysłany: 31-01-2019, 20:57   

Apollo i Kuma - systemy pracują. Jeszcze raz podziękowania. Temat można zamknąć. Pozdrawiam
ID posta: 361686 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe