Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70105 Skopiuj do schowka data w określonym zakresie
Autor Wiadomość
Kiluk 
Stały bywalec Excelforum



Pomógł: 6 razy
Posty: 438
Wysłany: 10-02-2021, 11:18   data w określonym zakresie

Cześć.
Mam zagwozdkę.
jak oznaczyć datę jako występującą gdy mieści się w zakresie dat

ciężko to pisać.
szukam np daty 31.07.2020 w komórce z kilkoma datami.
jak znajduje datę 31.07.2020 to oznaczam ja jako TAK
a chciałbym aby oznaczenie TAK pokazywało się jeżeli przeszukiwana komórka zawiera datę w zakresie np 25-ty do ostatni dzień.
czyli 27.07.2020 tez oznaczany jest jako TAK ponieważ mieści się w opisanym zakresie.

data z zakresu dat.xlsx
Pobierz Plik ściągnięto 5 raz(y) 10.64 KB

ID posta: 400090 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 2035 razy
Posty: 6432
Wysłany: 10-02-2021, 12:15   

Jeśli dobrze zrozumiałem można tak:
Kod:
=JEŻELI($B7>=H$1;"TAK";JEŻELI(ILE.LICZB(ZNAJDŹ({25;26;27;28;29;30;31}&PRAWY(TEKST(H$1;"dd.mm.rrr");8);$A7));"TAK";H$1))
Jest to formuła tablicowa, wymaga Ctrl+Shift+Enter, chyba że Excel 365, wtedy wystarczy samo Enter.
Może sposób identyfikacji dat mało wyrafinowany, ale ponieważ dni nie jest dużo, to najprościej je wylistować.

data z zakresu dat.xlsx
Pobierz Plik ściągnięto 4 raz(y) 11.7 KB

ID posta: 400096 Skopiuj do schowka
 
 
Kiluk 
Stały bywalec Excelforum



Pomógł: 6 razy
Posty: 438
Wysłany: 10-02-2021, 12:19   

zadziałało. dzięki.
nie wpadłbym żeby tak to "ugryźć"
nie chodzi o wyrafinowanie a o skuteczność :)
ID posta: 400097 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe