Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63759 Skopiuj do schowka wyszukaj pionowo?
Autor Wiadomość
jurekabr
Starszy Forumowicz


Pomógł: 1 raz
Posty: 49
Wysłany: 09-01-2019, 21:58   wyszukaj pionowo?

witam
mam w komórkach D37, D38, D39 nazwijmy to punktami będą to liczby zawsze wielokrotność 25, w komórkach E37, E38, E39 są ilości wielokrotności "25" chciałbym jak w przykładzie aby w komórce G37 wyliczało mi z kolumny B "DANE" sumę ale tylko 2 pierwszych sztuk czyli sumę z komórki B37 i B38 i analogicznie w komórce H37 wyliczało mi z kolumny B "DANE" sumę ale już 20 pierwszych sztuk czyli sumę od B37 do B56 i tak samo w komórce I37, punkty będą różne 50, 500, 750 to tylko przykład ale zawsze będzie to liczba podzielna do całości przez 25
z góry dziękuję za pomoc

test_04.xls
Pobierz Plik ściągnięto 12 raz(y) 28.5 KB

ID posta: 360143 Skopiuj do schowka
 
 
dm 
Excel Expert


Pomógł: 399 razy
Posty: 1165
Wysłany: 09-01-2019, 22:38   

Czy o to chodziło?

Kopia test_04.xls
Pobierz Plik ściągnięto 12 raz(y) 35 KB

ID posta: 360146 Skopiuj do schowka
 
 
jurekabr
Starszy Forumowicz


Pomógł: 1 raz
Posty: 49
Wysłany: 09-01-2019, 22:49   

to nie o to chodziło
punkty w kolumnie od D37 do D39 będą sie zmieniać np w D37 zamiast 50 będzie 100 komórka E37 pokaże wtedy wynik 4 co oznacza że w G37 powinna być suma od B37 do B40 (4 pierwsze z kolumny B "Dane")
ID posta: 360149 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1164 razy
Posty: 3483
Wysłany: 09-01-2019, 22:53   

W 'D37' i kopia w prawo
Kod:
=SUMA(PRZESUNIĘCIE($B$36;1;;ADR.POŚR("E"&NR.KOLUMNY(AK1))))
Pozdrawiam.
ID posta: 360150 Skopiuj do schowka
 
 
jurekabr
Starszy Forumowicz


Pomógł: 1 raz
Posty: 49
Wysłany: 09-01-2019, 23:09   

kurcze kuma sprawdzam sobie tak na szybko i wychodzi że jest OK tylko co oznacza i czemu służy komórka AK1 w podanym kodzie :?: czy mógłbyś jakoś w prosty sposób wytłumaczyć? a formuła rozumiem że raczej w G37 i kopia w prawo?
ID posta: 360152 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1164 razy
Posty: 3483
Wysłany: 09-01-2019, 23:35   

Oczywiście, że w G37!!!
Zapis
Kod:
=ADR.POŚR("E"&NR.KOLUMNY(AK1))
zwraca wartość z komórki E37, czyli 2.
NR.KOLUMNY(AK1) daje wartość 37, bo kolumna AK1 jest 37 w kolejności.
Myślę, że jasne.
Można również zapisać w G37, pomijając kolumnę E
Kod:
=SUMA(PRZESUNIĘCIE($B$36;1;;ADR.POŚR("D"&NR.KOLUMNY(AK1))/25))
Pozdrawiam.
ID posta: 360155 Skopiuj do schowka
 
 
jurekabr
Starszy Forumowicz


Pomógł: 1 raz
Posty: 49
Wysłany: 09-01-2019, 23:52   

jak ktoś wytłumaczy to prawie jasne ale sam bym nie wpadł :-)
dziękuję jeszcze raz
temat można zamknąć
ID posta: 360157 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe