Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70104 Skopiuj do schowka Wybieranie wartości jeśli w kolumnie obok jest zero
Autor Wiadomość
beret
ExcelGaduła 500+


Wersja: Win Office 2007
Pomógł: 13 razy
Posty: 784
Wysłany: 10-02-2021, 09:27   Wybieranie wartości jeśli w kolumnie obok jest zero

Jaką formułę do kolumny I, aby pobrała z kolumny C tylko te wartości, obok których w kolumnie B są wartości <>0 ?
ID posta: 400076 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 796 razy
Posty: 4303
Wysłany: 10-02-2021, 09:36   

W I1:
Kod:
=JEŻELI($B1<>0;$C1;"")
i kopia w dół.
.
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 400078 Skopiuj do schowka
 
 
beret
ExcelGaduła 500+


Wersja: Win Office 2007
Pomógł: 13 razy
Posty: 784
Wysłany: 10-02-2021, 09:45   

Nie tak.
Chodzi o to, aby w kolumnie I nie było "dziur".
Np.
W kolumnie B jest tak:
12
0
14
0
0
1
W kolumnie C tak:
Ala
Ola
Kola
Bolek
Lolek
Miś
Wtedy w kolumnie I ma być tak:
Ala
Kola
Miś
ID posta: 400079 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 796 razy
Posty: 4303
Wysłany: 10-02-2021, 09:55   

Wstaw w wiersz 1 jakieś nagłówki > zaznacz kol. I > Dane > Filtruj > odhacz "Puste".
Albo VBA.
.
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 400081 Skopiuj do schowka
 
 
beret
ExcelGaduła 500+


Wersja: Win Office 2007
Pomógł: 13 razy
Posty: 784
Wysłany: 10-02-2021, 10:32   

To ja wiem.
Mnie chodzi o to, aby to zrobić jakąś formułą.
ID posta: 400084 Skopiuj do schowka
 
 
kuma 
Excel Expert


Wersja: Win Office 2010
Pomógł: 1453 razy
Posty: 4169
Wysłany: 10-02-2021, 11:15   

Dwie możliwości. Dla Ex 2007 może być formuła tablicowa.
Kod:
=JEŻELI.BŁĄD(INDEKS(C:C;MIN.K(JEŻELI($B$1:$B$20>0;WIERSZ($B$1:$B$20);"");WIERSZ()));"")
Dla "nowszego" Ex taka, zwykła formuła.
Kod:
=JEŻELI.BŁĄD(INDEKS(C:C;AGREGUJ(15;6;WIERSZ($B$1:$B$20)/($B$1:$B$20>0);WIERSZ()));"")
_________________
Pozdrawiam.
ID posta: 400089 Skopiuj do schowka
 
 
beret
ExcelGaduła 500+


Wersja: Win Office 2007
Pomógł: 13 razy
Posty: 784
Wysłany: 10-02-2021, 12:02   

Dzięki.
O to chodziło.
ID posta: 400094 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe