Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 67771 Skopiuj do schowka suma na podstawie liczb i znaków
Autor Wiadomość
kamilkamil
Stały bywalec Excelforum


Posty: 263
Wysłany: 07-04-2020, 12:28   suma na podstawie liczb i znaków

Cześć,
mam tebele gdzie wpisywane są zarówno cyfry jak i litery.
w arkuszu2 jest legenda z literami i przypisanymi do nich wartościami.
Jak zsumować to w tabeli w arkusz1?

Dzięki

suma.xlsx
Pobierz Plik ściągnięto 10 raz(y) 10.01 KB

ID posta: 385144 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 612 razy
Posty: 3260
Wysłany: 07-04-2020, 12:50   

w L2:
Kod:
=JEŻELI(CZY.LICZBA(B2);B2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(C2);C2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(C2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(D2);D2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(D2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(E2);E2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(E2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(F2);F2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(F2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(G2);G2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(G2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(H2);H2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(H2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(I2);I2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(I2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(J2);J2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(J2;Arkusz2!A1:B6;2;0);0)) + JEŻELI(CZY.LICZBA(K2);K2;JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(K2;Arkusz2!A1:B6;2;0);0))
i kopia w dół.
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 385149 Skopiuj do schowka
 
 
kamilkamil
Stały bywalec Excelforum


Posty: 263
Wysłany: 07-04-2020, 13:00   

dzięki,
To jest jedyna opcja? w przykładzie podałem tylko 10 kolumn. normalnie będę miał ich koło 100.
Można to rozwiązać np jakimś kodem ?
ID posta: 385152 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2624 razy
Posty: 4426
Wysłany: 07-04-2020, 13:21   

Kod:
=SUMA.ILOCZYNÓW((B2:K2=Arkusz2!A$1:A$6)*(Arkusz2!B$1:B$6))+SUMA(B2:K2)

i kopia w dół
_________________
Pozdrawiam
Asia
ID posta: 385153 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 330 razy
Posty: 1040
Wysłany: 07-04-2020, 13:21   

Funkcja tablicowa dla L2 i kopia w dół:
Kod:
=SUMA(JEŻELI.BŁĄD(WYSZUKAJ(B2:K2;Arkusz2!$A$1:$A$6;Arkusz2!$B$1:$B$6);B2:K2))
_________________
Pozdrawiam
xFish
ID posta: 385155 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 612 razy
Posty: 3260
Wysłany: 07-04-2020, 13:25   

VBA. Na sztywno do 8-go wiersza (ilość kolumn: dowolna).
.

Kopia suma.xlsm
Pobierz Plik ściągnięto 3 raz(y) 21.69 KB

_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 385156 Skopiuj do schowka
 
 
kamilkamil
Stały bywalec Excelforum


Posty: 263
Wysłany: 07-04-2020, 13:50   

Dzieki wszystkim za pomoc
ID posta: 385160 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe