Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70169 Skopiuj do schowka Pobranie danych (odpowiedniej sumy) z innej tabeli
Autor Wiadomość
maciek_m 
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 44
Wysłany: 17-02-2021, 17:02   Pobranie danych (odpowiedniej sumy) z innej tabeli

Mam tabelę z której muszę pobrać dane do innej tabeli a konkretniej sumę z odpowiednich zakresów. Potrzebuję uniwersalnej formuły która wypełni drugą tabelę, aby wyszukała odpowiednie dane i zsumowała zakres od.. do.. Przykład w załączeniu.

Pobranie sumy.xlsx
Pobierz Plik ściągnięto 10 raz(y) 11.34 KB

ID posta: 400558 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2747 razy
Posty: 4607
Wysłany: 17-02-2021, 17:22   

np. w F12 taki
Kod:
=SUMA(PRZESUNIĘCIE($C$3;PODAJ.POZYCJĘ($E12;$B$3:$B$8;0)-1;;;PRAWY(F$11;DŁ(F$11)-ZNAJDŹ("-";F$11))))

i kopia w prawo i w dół
_________________
Pozdrawiam
Asia
ID posta: 400560 Skopiuj do schowka
 
 
maciek_m 
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 44
Wysłany: 17-02-2021, 19:38   

Dzięki, działa. A można jeszcze rozbudować formułę tak aby pobierała dane np. z co drugiej kolumny? Nagłówki w tabelach mogą być zmienione jeśli to miało by uprościć (ułatwić) formułę.

Pobranie sumy1.xlsx
Pobierz Plik ściągnięto 5 raz(y) 11.95 KB

ID posta: 400563 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2747 razy
Posty: 4607
Wysłany: 17-02-2021, 20:19   

w H12
Kod:
=SUMA.ILOCZYNÓW(($B$3:$B$8=$G12)*($C$2:$U$2>=1)*($C$2:$U$2<=--PRAWY(H$11;DŁ(H$11)-ZNAJDŹ("-";H$11)))*($C$2:$U$2<>"x")*($C$3:$U$8))

i kopia w prawo i w dół
_________________
Pozdrawiam
Asia
ID posta: 400568 Skopiuj do schowka
 
 
maciek_m 
Starszy Forumowicz


Wersja: Win Office 2016
Posty: 44
Wysłany: 18-02-2021, 19:14   

Dzięki, o to mi chodziło. :-)
ID posta: 400641 Skopiuj do schowka
 
 
DwaNiedźwiedzie 
Excel Expert



Wersja: Win Office 2016
Pomógł: 279 razy
Posty: 686
Wysłany: 18-02-2021, 19:47   

Podrzucam jeszcze rozwiązanie w Power Query, z dowolnym skokiem i obojętne na nazwy kolumn.

Pobranie sumy1-1 DN.xlsx
Pobierz Plik ściągnięto 1 raz(y) 23.24 KB

ID posta: 400642 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe