Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64038 Skopiuj do schowka Osoby pracujące w danym dniu na podstawie grafiku
Autor Wiadomość
miko
świeżak


Posty: 8
Wysłany: 04-02-2019, 21:55   Osoby pracujące w danym dniu na podstawie grafiku

Witam wszystkich,

mam utworzony przykładowy grafik na miesiąc luty, chciałbym aby po wyborze dnia w arkuszu Stany pojawiały się tylko osoby pracujące w tym dniu ze swoich sekcji. Jakich formuł mam użyć aby uzyskać zamierzony efekt? VBA nie wchodzi w grę ;-)

Grafik.xlsx
Pobierz Plik ściągnięto 20 raz(y) 14.55 KB

ID posta: 361960 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1565 razy
Posty: 4932
Wysłany: 05-02-2019, 07:53   

Najprościej to tak, jak w załączniku.

Grafik (2).xlsx
Pobierz Plik ściągnięto 24 raz(y) 14.81 KB

ID posta: 361970 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2435 razy
Posty: 4125
Wysłany: 05-02-2019, 15:58   

w C4 wklej
Kod:
=JEŻELI.BŁĄD(INDEKS(Grafik!$A:$A;MIN.K(JEŻELI(CZY.LICZBA(PRZESUNIĘCIE(Grafik!$B$5;PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)-4;PODAJ.POZYCJĘ($G$3;Grafik!$3:$3;0)-2;JEŻELI.BŁĄD(PODAJ.POZYCJĘ(D$3;Grafik!$A:$A;0)-PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)-1;ILE.NIEPUSTYCH(Grafik!$A:$A)-PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)+2)));WIERSZ(PRZESUNIĘCIE(Grafik!$B$5;PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)-4;PODAJ.POZYCJĘ($G$3;Grafik!$3:$3;0)-2;JEŻELI.BŁĄD(PODAJ.POZYCJĘ(D$3;Grafik!$A:$A;0)-PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)-1;ILE.NIEPUSTYCH(Grafik!$A:$A)-PODAJ.POZYCJĘ(C$3;Grafik!$A:$A;0)+2)));"");WIERSZ(1:1)));"")

zatwierdź klawiszami Ctrl+Shift+Enter i kopia w prawo i w dół
_________________
Pozdrawiam
Asia
ID posta: 362005 Skopiuj do schowka
 
 
miko
świeżak


Posty: 8
Wysłany: 05-02-2019, 16:51   

Dziękuję za pomoc :beer

Asia_@. czeka mnie trochę czasu zanim ogarnę w 100 % Twoją formułę :mrgreen:
ID posta: 362008 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe