Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63715 Skopiuj do schowka Mój grafik
Autor Wiadomość
plake 
Starszy Forumowicz


Posty: 36
Wysłany: 07-01-2019, 19:16   Mój grafik

Witam
W załączeniu wysyłam swój grafik.
Są dwa arkusze "Grafik" i "Suma" będę jeszcze chciał to rozbudować o "Druk".
"Grafik" - to lista pielęgniarek które zajmują się podopiecznymi.
"Suma" - sumuje wypracowane godziny oraz podaje kwotę do wpłaty przez podopiecznego.
"Druk" - w przyszłości chcę zrobić wzór druku wpłaty i drukować go podopiecznym.
"Grafik" i "Suma" powiązane są formułami - sam sobie je tak wymyśliłem.
Problem pojawia mi się jak dochodzi nowa osoba (zaznaczona na czerwono) w arkuszu "Grafik". Ja sobie z nową osobą poradzę ale moja "starsza pielęgniarka" która to prowadzi nie zrobi tego.
Czu można użyć formuł lub makr do większego zautomatyzowania moich arkuszy.
Chodzi o to aby przy pojawieniu się nowej osoby w arkuszu "Grafik" automatycznie pojawiała się w arkuszu "Suma" no i aby automatycznie liczyło godziny i kwotę.
Dodam jeszcze że dany podopieczny może być pod opieką kilku pielęgniarek.
Podopiecznych nie będzie więcej niż 40.
Mam wersję excela 2007.
Z góry dziękuję za podpowiedzi i pomoc.

Grafik.xls
Pobierz Plik ściągnięto 17 raz(y) 72.5 KB

ID posta: 359921 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2357 razy
Posty: 4008
Wysłany: 07-01-2019, 20:26   

formułą tablicową

Grafik (2).xls
Pobierz Plik ściągnięto 32 raz(y) 102.5 KB

_________________
Pozdrawiam
Asia
ID posta: 359926 Skopiuj do schowka
 
 
blondi 
Starszy Forumowicz



Pomogła: 1 raz
Posty: 38
Wysłany: 07-01-2019, 21:48   

Cytat:
=JEŻELI($X6="niedziela";SUMA(INDEKS(I$1:I$35;_xlfn.IFERROR(MIN.K(INDEKS((($X$1:$X6)<>"poniedziałek")*10^4+WIERSZ($1:6);0);LICZ.JEŻELI($X$1:$X6;"poniedziałek"));3)):I6);"")



jak mogę to zapisać, żeby działało w excel 2003 ;)
ID posta: 359940 Skopiuj do schowka
 
 
plake 
Starszy Forumowicz


Posty: 36
Wysłany: 08-01-2019, 16:56   

Dziękuję Asia_@. :-D
Bardzo fajne rozwiązanie.
Niestety jak dopisuję do obojętnie której pielęgniarki osobę z nazwiskiem zaczynającym się na A (Np. Adamski) to przestaje działać.
Dopisując w polu nazwisko samą literę A też nie działa. Jak dopisuję samą literę B lub nazwisko zaczynające się na B to działa.
Zauważyłem też że jak dopiszę najpierw samo B (w polu nazwisko) to działa i potem dodam osobą na A (Adamski) to już działa. Ale jak wykasuję osobę na B to przestaje działać.
Nie wiem dlaczego tak jest.
Bardzo proszę o pomoc.
Z góry dziękuję.
ID posta: 359994 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2357 razy
Posty: 4008
Wysłany: 08-01-2019, 17:30   

zamień na
Kod:
=JEŻELI(CZY.BŁĄD(PODAJ.POZYCJĘ(MIN(JEŻELI((Grafik!D$3:D$68<>"")*CZY.LICZBA(Grafik!C$3:C$68)*(LICZ.JEŻELI(B$2:B2;Grafik!D$3:D$68)=0);LICZ.JEŻELI(Grafik!D$3:D$68;"<="&Grafik!D$3:D$68)+1;2^99));LICZ.JEŻELI(Grafik!D$3:D$68;"<="&Grafik!D$3:D$68)+1;0));"";INDEKS(Grafik!D$3:D$68;PODAJ.POZYCJĘ(MIN(JEŻELI((Grafik!D$3:D$68<>"")*CZY.LICZBA(Grafik!C$3:C$68)*(LICZ.JEŻELI(B$2:B2;Grafik!D$3:D$68)=0);LICZ.JEŻELI(Grafik!D$3:D$68;"<="&Grafik!D$3:D$68)+1;2^99));LICZ.JEŻELI(Grafik!D$3:D$68;"<="&Grafik!D$3:D$68)+1;0)))
_________________
Pozdrawiam
Asia
ID posta: 359999 Skopiuj do schowka
 
 
plake 
Starszy Forumowicz


Posty: 36
Wysłany: 08-01-2019, 19:42   

Dziękuję za pomoc - działa poprawnie - punkt za pomoc dodany.

Mam jeszcze prośbę: rozbudowałem swój arkusz o druk (plik w załączeniu).

Zastanawiam się jak to zrobić:
- Utworzyłem wzór dowodu wpłaty.
- Dla każdej pozycji z listy będzie dowód wpłaty (Druk 01, Druk 02 itd.)
Aby mieć kwotę słownie skorzystałem z rozwiązania Marcina Egerta.
Na wydruku dowodu wpłaty potrzebny jest adres osoby wpłacającej.
No i tu nie wiem jak to rozwiązać...

Utworzyłem arkusz "Baza adresowa" >> tam wprowadzam adresy do każdego nazwiska.
Czy da się powiązać formułą tak aby w arkuszu "Suma" automatycznie pojawiał się adres przy nazwisku "zassany" z arkusza "Baza adresowa". Wtedy dane z arkusza "Suma" będę "wiązał" z arkuszami Druk 01, Druk 02 itd.

A może są jeszcze inne rozwiązania?

Z góry dziękuję za pomoc.


Przeredagowałem twoją wypowiedź - jednorazowo - następny taki bełkotliwy post stosownie "nagrodzę" (ostrzeżeniem - jakbyś się nie domyślił).
umiejead

.

Grafik tablicowy.xls
Pobierz Plik ściągnięto 15 raz(y) 421 KB

ID posta: 360011 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1483 razy
Posty: 4768
Wysłany: 09-01-2019, 09:25   

W arkuszu Suma w E3 wstaw:
Kod:
=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B3;'Baza adresowa'!$B$2:$C$5;2;0);"")
i przeciągnij w dół.
Zakres $B$2:$C$5 dopasuj do swoich potrzeb.
ID posta: 360057 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2357 razy
Posty: 4008
Wysłany: 09-01-2019, 14:00   

propozycja w załączniku
w komórce B12 w arkuszu Druk jest lista rozwijana z kórej wybierasz Nazwisko i imię

Grafik tablicowy_1.xls
Pobierz Plik ściągnięto 16 raz(y) 142 KB

_________________
Pozdrawiam
Asia
ID posta: 360089 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4257
Wysłany: 09-01-2019, 14:53   

plake napisał/a:
Dziękuję za pomoc - działa poprawnie - punkt za pomoc dodany.

Formuła tablicowa dla suma!B3
Kod:

=JEŻELI.BŁĄD(INDEKS(Grafik!D$3:D$68;PODAJ.POZYCJĘ(0;JEŻELI((Grafik!D$3:D$68<>"")*CZY.LICZBA(Grafik!C$3:C$68);LICZ.JEŻELI(B$2:B2;Grafik!D$3:D$68);"");0));"")

zakończona Ctrl + Shift + Enter
ID posta: 360093 Skopiuj do schowka
 
 
plake 
Starszy Forumowicz


Posty: 36
Wysłany: 09-01-2019, 21:13   

apollo

Dziękuję za podpowiedź.
Powyższa formuła nie sortuje alfabetycznie nazwisk.

plake w dniu: 09-01-2019, 21:18 napisał/a:
Bardzo dziękuję Asia za pomoc i bardzo fajne rozwiązanie.
Pozdrawiam serdecznie

edycja Zbiniek:
1. Proszę korzystać z opcji edytowania wypowiedzi – przycisk „edytuj”. Opcja jest dostępna bodajże przez 30 minut od momentu wysłania wypowiedzi.
2. Nie cytuj całej wypowiedzi znajdującej się bezpośrednio powyżej – w takim przypadku wiadomo, że się do niej odnosisz. Cytowanie stosuj tylko wtedy, gdy nawiązujesz do wypowiedzi o kilka postów wcześniej lub gdy komentujesz tylko jakiś fragment ostatniej wypowiedzi. W obu przypadkach zacytuj tylko fragment, do którego się odnosisz.
ID posta: 360136 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4257
Wysłany: 09-01-2019, 21:43   

plake napisał/a:
apollo napisał/a:

Formuła tablicowa dla suma!B3
Kod:

=JEŻELI.BŁĄD(INDEKS(Grafik!D$3:D$68;PODAJ.POZYCJĘ(0;JEŻELI((Grafik!D$3:D$68<>"")*CZY.LICZBA(Grafik!C$3:C$68);LICZ.JEŻELI(B$2:B2;Grafik!D$3:D$68);"");0));"")

zakończona Ctrl + Shift + Enter


Dziękuję za podpowiedź.
Powyższa formuła nie sortuje alfabetycznie nazwisk.

Ja czytałem post #1 i ściągnąłem dołączony plik. Nigdzie w poście ani w pliku nie napisałeś, że wyniki muszą być posortowane.

Ja zwyczajnie nie zwróciłem uwagi na to, ze podałeś dane posortowane.

Na przyszłość napisz wyraźnie, nie każ innym sprawdzić i domyślić.
ID posta: 360142 Skopiuj do schowka
 
 
plake 
Starszy Forumowicz


Posty: 36
Wysłany: 10-01-2019, 13:43   

Asia_@. napisał/a:
propozycja w załączniku
w komórce B12 w arkuszu Druk jest lista rozwijana z kórej wybierasz Nazwisko i imię


Jeszcze raz poproszę o pomoc.
Pracujemy na propozycji Asi - plik o nazwie grafik_tablicowy_1

W arkuszu "Suma" mam podane wszystkie osoby - moi podopieczni.

Czy da się tak zrobić aby w arkuszu "Baza adresowa" w kolumnie B też automatycznie pojawiały mi się wszystkie osoby - moi podopieczni. W kolumnie C (Adres) będę sobie tylko uzupełniał ich adresy.

Jeżeli będę miał w arkuszu "Baza adresowa" automatycznie wszystkich moich podopiecznych to będę widział dla kogo uzupełnić adres

Z góry dziękuję za pomoc.
ID posta: 360190 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1483 razy
Posty: 4768
Wysłany: 11-01-2019, 11:20   

W arkuszu "Baza adresowa" w B2 wstaw formułę:
Kod:
=JEŻELI(Suma!B3="";"";Suma!B3)
i przeciągnij w dół
ID posta: 360228 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2357 razy
Posty: 4008
Wysłany: 11-01-2019, 11:51   

plake napisał/a:
Czy da się tak zrobić aby w arkuszu "Baza adresowa" w kolumnie B też automatycznie pojawiały mi się wszystkie osoby - moi podopieczni. W kolumnie C (Adres) będę sobie tylko uzupełniał ich adresy.

jeżeli w arkuszu Baza adresowa w kolumnie B automatycznie pojawią się wszystkie osoby to kolumna C z adresami "rozjedzie" się
możesz w arkuszu Druk w B14 wkleić taki
Kod:
=JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO(B12;'Baza adresowa'!B2:C41;2;0));"BRAK ADRESU";WYSZUKAJ.PIONOWO(B12;'Baza adresowa'!B2:C41;2;0))


Grafik tablicowy_1.xls
Pobierz Plik ściągnięto 16 raz(y) 138 KB

_________________
Pozdrawiam
Asia
ID posta: 360234 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe