Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64049 Skopiuj do schowka lista posiadaczy kursów
Autor Wiadomość
madyd 
forumowicz


Posty: 18
Wysłany: 05-02-2019, 21:46   lista posiadaczy kursów

Witam, Mam pytanie, prośbę. Ma ktoś jakiś pomysł jak zrobić w excel coś takiego, że po wybraniu interesującego mnie kursu wyświetlało mi listę nazwisk osób, które posiadają wybrany kurs? Próbowałem walczyć z tematem, ale niestety coś mi nie wychodzi.... Jeszcze nie ten poziom :-)
W załączeniu podaję przykład. Są 3 arkusze. Arkusz Nr 1 "DANE" w nim są dane osobowe oraz kod kursu jaki kto posiada. Arkusz Nr 2 "WYKAZ_KURSOW" w nim są oznaczenia kod kursu oraz co który kod kursu oznacza. Arkusz Nr 3 "WYNIK" w nim po wybraniu z listy rozwijanej kursu jaki mnie interesuje potrzebowałbym żeby wyświetliła mi się lista nazwisk, które posiadają wybrany kurs w firmie. Macie jakieś pomysły jak to zrobić? Będę wdzięczny za pomoc. Dziękuję.

PRZYKŁAD.xlsx
Pobierz Plik ściągnięto 11 raz(y) 10.92 KB

ID posta: 362026 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1236 razy
Posty: 4306
Wysłany: 05-02-2019, 22:36   

W arkuszu WYKAZ_KURSOW kod 1 nie ma nazwy a przecież on występuje w DANE. Kod 6 ma nazwę a nie występuje w DANE. Popraw dane.
Formuła dla A7
Kod:

=INDEKS(WYKAZ_KURSOW!A$2:A$50;PODAJ.POZYCJĘ(B$2;WYKAZ_KURSOW!B$2:B$50;0))

Kopiuj w dół

Formuła dla B7
Kod:

=INDEKS(DANE!B$2:B$50;AGGREGATE(15;6;WIERSZ($1:$50)/LICZ.JEŻELI(PRZESUNIĘCIE(DANE!$E$1;WIERSZ($1:$50);;;5);$A7);ILE.WIERSZY($A$1:$A1)))

Kopiuj w prawo do C7 i dalej w dól
ID posta: 362034 Skopiuj do schowka
 
 
madyd 
forumowicz


Posty: 18
Wysłany: 05-02-2019, 23:20   

Dzięki, uwagi poprawiłem. Natomiast coś jeszcze nie chce mi działać podana formuła w B7 i dalej.

PRZYKŁAD.xlsx
Pobierz Plik ściągnięto 8 raz(y) 14.47 KB

ID posta: 362038 Skopiuj do schowka
 
 
Cezary Czajka 
Excel Expert


Wersja: Win Office 2019
Pomógł: 140 razy
Posty: 676
Wysłany: 05-02-2019, 23:37   

Aż się prosi Power Query + Tabela Przestawna ;-)

PRZYKŁAD.xlsx
Pobierz Plik ściągnięto 13 raz(y) 27.29 KB

_________________
W sumie - jest git
ID posta: 362041 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1236 razy
Posty: 4306
Wysłany: 06-02-2019, 00:02   

madyd napisał/a:
Dzięki, uwagi poprawiłem. Natomiast coś jeszcze nie chce mi działać podana formuła w B7 i dalej.

Nie wiem, dlaczego masz błąd.

Ja po otwarciu Twojego pliku widziałem same błędy. Po dwukliku w B7 i Enter miałem poprawny wynik. Potem tylko kopiowałem w prawo i w dół

PRZYKŁAD.xlsx
Pobierz Plik ściągnięto 17 raz(y) 15.21 KB

ID posta: 362044 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe