Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 67733 Skopiuj do schowka jeżeli komórka zawiera fragment tekst - problem
Autor Wiadomość
inax
świeżak


Wersja: Mac Office 365
Posty: 6
Wysłany: 03-04-2020, 13:32   jeżeli komórka zawiera fragment tekst - problem

Cześć,
mam chyba banalny problem ale nie umiem go rozwiązać.

komórki zawierają opisy:
B2 - materiał zielony matowy
B3 - materiał zielony błysk
B4 - materiał zielony satyna
B5 - materiał czarny błysk
itd

W komórce obok muszę wyciągnąć informacje czy materiał jest błysk, mat czy satyna.
Nie umiem zrobić funkcji JEŻELI tak aby wyszukała czy cały tekst zawiera dane słowo np "błysk" i wstawiła to słowo do komórki obok.

Proszę o pomoc.
ID posta: 384855 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2626 razy
Posty: 4430
Wysłany: 03-04-2020, 13:50   

Kod:
=PRAWY(B2;DŁ(B2)-ZNAJDŹ("#";PODSTAW(B2;" ";"#";DŁ(B2)-DŁ(PODSTAW(B2;" ";"")))))
_________________
Pozdrawiam
Asia
ID posta: 384856 Skopiuj do schowka
 
 
inax
świeżak


Wersja: Mac Office 365
Posty: 6
Wysłany: 03-04-2020, 13:57   

O rany, miałem nadzieję że uda się to zrobić łatwiej. Ogólnie w sporej ilości komórek nie jest zachowana kolejność czyli nie zawsze "matowy" czy "błysk" jest na końcu.

Jako że mam tylko 3 warianty (matowy, błysk, satyna) nie dałoby się tego zrobić funkcją JEŻELI?
Niestety to mam poniżej nie działa bo funkcją JEŻELI wyszukuje tylko komórkę jako całość, a nie fragment tekstu. Czy da się w poniższej formule zrobić tak aby wyszukał z całego tekstu fragment "błysk" i jeśli jest znajdzie to wstawia błysk, a jak nie to matowy?

Kod:
=JEŻELI(B2="błysk";"błysk";"matowy")
ID posta: 384858 Skopiuj do schowka
 
 
Artik 



Wersja: Win Office 365
Pomógł: 2890 razy
Posty: 9579
Wysłany: 03-04-2020, 14:14   

Warunek zwracający tylko czy wskazany tekst (B2) zawiera jedno ze słów:
Kod:
=(JEŻELI.BŁĄD(ZNAJDŹ("matowy";B2);0)+JEŻELI.BŁĄD(ZNAJDŹ("satyna";B2);0)+JEŻELI.BŁĄD(ZNAJDŹ("błysk";B2);0))>0

Działające paskudztwo. :-)

Artik
_________________
Persistence is a virtue in the world of programming.
ID posta: 384860 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Wersja: Win Office 2019
Pomógł: 2368 razy
Posty: 7756
Wysłany: 03-04-2020, 14:15   

Toż to szooook, Artik, zapodał formułę !!!! :-D
Dla starszych wersji
Kod:
=JEŻELI(CZY.BŁĄD(ZNAJDŹ("matowy";B2));JEŻELI(CZY.BŁĄD(ZNAJDŹ("błysk";B2));"satyna";"błysk");"matowy")
_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Office 2019 Professional Plus , Windows 10 x64
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 384861 Skopiuj do schowka
 
 
Artik 



Wersja: Win Office 365
Pomógł: 2890 razy
Posty: 9579
Wysłany: 03-04-2020, 14:21   

Marek, jest mały problem. Twoja formuła zwraca "satyna", gdy brak w tekście wszystkich wymienionych w formule słów. (A wynik swojej formuły przemilczę. :-) )

Artik
_________________
Persistence is a virtue in the world of programming.
ID posta: 384863 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Wersja: Win Office 2019
Pomógł: 2368 razy
Posty: 7756
Wysłany: 03-04-2020, 14:39   

Oki, poprawione.
Kod:
=JEŻELI(CZY.BŁĄD(ZNAJDŹ("matowy";B2));JEŻELI(CZY.BŁĄD(ZNAJDŹ("błysk";B2));JEŻELI(CZY.BŁĄD(ZNAJDŹ("satyna";B2));"byk";"satyna");"błysk");"matowy")
_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Office 2019 Professional Plus , Windows 10 x64
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 384865 Skopiuj do schowka
 
 
Artik 



Wersja: Win Office 365
Pomógł: 2890 razy
Posty: 9579
Wysłany: 03-04-2020, 14:51   

A ja, jak zwykle, poleciałem na około:
Kod:
=JEŻELI((JEŻELI.BŁĄD(ZNAJDŹ("matowy";B2);0)+JEŻELI.BŁĄD(ZNAJDŹ("satyna";B2);0)+JEŻELI.BŁĄD(ZNAJDŹ("błysk";B2);0))*1>0;
JEŻELI(CZY.BŁĄD(ZNAJDŹ("matowy";B2));"";FRAGMENT.TEKSTU(B2;ZNAJDŹ("matowy";B2);DŁ("matowy")))&
JEŻELI(CZY.BŁĄD(ZNAJDŹ("satyna";B2));"";FRAGMENT.TEKSTU(B2;ZNAJDŹ("satyna";B2);DŁ("satyna")))&
JEŻELI(CZY.BŁĄD(ZNAJDŹ("błysk";B2));"";FRAGMENT.TEKSTU(B2;ZNAJDŹ("błysk";B2);DŁ("błysk")));"")
:mrgreen:

Wiem, wygląda tak, jak bym w VBA używał Select-ów :haha

Artik
_________________
Persistence is a virtue in the world of programming.
ID posta: 384867 Skopiuj do schowka
 
 
inax
świeżak


Wersja: Mac Office 365
Posty: 6
Wysłany: 03-04-2020, 15:29   

Niestety ale w każdym wypadku zwraca "błysk" nawet gdy powinno zwrócić "mat"

Próbowałem też skrócić formułę ale cały czas tylko błysk.
Kod:
=JEŻELI(CZY.BŁĄD(ZNAJDŹ("błysk";B2));"błysk";"matowy")
ID posta: 384870 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 880 razy
Posty: 3556
Wysłany: 03-04-2020, 15:31   

Siem bawicie :mrgreen:
Kod:
=INDEKS({"satyna";"błysk";"matowy"};PODAJ.POZYCJĘ(1;PODAJ.POZYCJĘ("*"&{"satyna";"błysk";"matowy"}&"*";B2:B2;0);0))
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 384871 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Wersja: Win Office 2019
Pomógł: 2368 razy
Posty: 7756
Wysłany: 03-04-2020, 15:39   

inax napisał/a:
niestety ale w każdym wypadku zwraca "błysk"

inax, Prima Aprilis się już skończył, a może wcześniejsze błyski Cię oślepiły.
Patrz załącznik.

inax.xlsx
Pobierz Plik ściągnięto 5 raz(y) 10.05 KB

_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Office 2019 Professional Plus , Windows 10 x64
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 384872 Skopiuj do schowka
 
 
inax
świeżak


Wersja: Mac Office 365
Posty: 6
Wysłany: 03-04-2020, 15:50   

Działa, problem był gdzie indziej bo miałem w komórkach BŁYSK dużymi literami, nie wiedziałem że to tak istotne.

Wielkie dzięki za pomoc.
ID posta: 384876 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 191 razy
Posty: 669
Wysłany: 03-04-2020, 15:53   

Formula
Kod:
=JEŻELI.BŁĄD(INDEKS(B$2:B$200;AGREGUJ(15;6;WIERSZ($1:$200)/(SZUKAJ.TEKST(D$2;B$2:B$200)>0);ILE.WIERSZY($2:2)));"")


Book1.xlsx
Pobierz Plik ściągnięto 4 raz(y) 8.61 KB

ID posta: 384878 Skopiuj do schowka
 
 
Marek P
świeżak


Posty: 3
Wysłany: 10-04-2020, 12:01   Szukaj.Tekst

Kochani teraz ja mam pytanie bardzo proszę o pomoc :
Kod:
=JEŻELI(SZUKAJ.TEKST("a1s";C2;1);"";JEŻELI(SZUKAJ.TEKST("-ep-*-A1";C2;1);10;JEŻELI(SZUKAJ.TEKST("-ll-*-A1";C2;1);10;0)))

W tej chwili formuła traktuje A1S że spełnia warunek jaki chcę, a chcę tylko wyszukać A1 nie A1S.
Co mam zrobić aby wstawiło w pole 10 jeśli inne pole będzie w tekście zawierało A1 nie A1S

Edit: Marecki
Przy wpisywaniu kodów makr lub formuł używaj znaczników [code] (zgodnie z pkt. 3.1 Regulaminu naszego forum).
_________________
Marek
ID posta: 385436 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe