Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64100 Skopiuj do schowka Automatyczne wypełnienie tabelki na podstawie daty zdarzenia
Autor Wiadomość
Zdancu
świeżak


Posty: 6
Wysłany: 11-02-2019, 17:35   Automatyczne wypełnienie tabelki na podstawie daty zdarzenia

Jak w temacie. Chcę żeby Excel automatycznie wypełnił tabelkę danymi z innej tabelki.
Żeby po wpisaniu daty w 1 tabelce umieścił tą datę wraz z danymi w 2 tabelce, oczywiście od najwcześniejszej do najpóźniejszej.
link do screena:
CIACH

edycja Zbiniek:
Załącz plik bezpośrednio na forum (zgodnie z pkt. 2.4 Regulaminu naszego forum); na naszym forum plik ma szansę być dłużej niż na wielu innych serwerach. Część osób ma ograniczony w pracy dostęp do takich serwerów. Często jeśli nie jesteśmy zarejestrowanym użytkownikiem, to trzeba czekać na możliwość ściągnięcia i jeszcze inne (np. wyskakujące okienka). Dostępne formaty załączników znajdziesz w Regulaminie.


Zeszyt100od.xlsx
Pobierz Plik ściągnięto 6 raz(y) 10.19 KB

  
ID posta: 362367 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 157 razy
Posty: 568
Wysłany: 11-02-2019, 19:09   

formuly
1.data
Kod:
=JEŻELI.BŁĄD(AGREGUJ(15;6;$C$4:$G$9/($C$4:$G$9<>"");ILE.WIERSZY($4:4));"")

2."dane poierane z wiersza 3"
Kod:
=JEŻELI.BŁĄD(INDEKS($C$3:$G$3;;AGREGUJ(15;6;NR.KOLUMNY($A:$G)/($C$4:$G$9=J4)/($C$4:$G$9<>"");1));"")

3."dane pobierane z kolumny B
Kod:
=JEŻELI.BŁĄD(INDEKS(B$4:B$9;AGREGUJ(15;6;WIERSZ($1:$15)/($C$3:$G$3=L4)/($C$4:$G$9=J4)/($C$4:$G$9<>"");1));"")


Zeszyt100od.xlsx
Pobierz Plik ściągnięto 5 raz(y) 10.86 KB

  
ID posta: 362374 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1212 razy
Posty: 4186
Wysłany: 11-02-2019, 19:39   

Czy daty w C4:G9 są różne parami czy mogą się powtarzać? Bo formuła poprawna w jednym przypadku może być niepoprawna w drugim.
Np. masz E7 = 2018-03-09. Czy może być E5 = 2018-03-09?
ID posta: 362377 Skopiuj do schowka
 
 
Zdancu
świeżak


Posty: 6
Wysłany: 12-02-2019, 06:42   

Dzięki Czesław bardzo mi to pomogło.
Z tym że, jak zauważył apollo, daty mogą się powtarzać.
Po dodaniu takiej samej daty zaczytuje błędne dane.
Da się to poprawić?
ID posta: 362409 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 157 razy
Posty: 568
Wysłany: 12-02-2019, 14:58   

Poprawiony zalacznik

Zeszyt100od.xlsx
Pobierz Plik ściągnięto 7 raz(y) 11.14 KB

ID posta: 362456 Skopiuj do schowka
 
 
Zdancu
świeżak


Posty: 6
Wysłany: 13-02-2019, 10:21   

Dzięki wszystkim za pomoc. Wszystko śmiga aż miło. Pozdrawiam.
ID posta: 362509 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe