Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70081 Skopiuj do schowka Adres do innego pliku jako zmienna w formule wyszukiwania
Autor Wiadomość
Uneasy 
Świeżak


Wersja: Win Office 2013
Posty: 1
Wysłany: 07-02-2021, 23:51   Adres do innego pliku jako zmienna w formule wyszukiwania

Cześć,

Mam poniższą składnię formuły:
Kod:

=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(A6;'C:\Users\Krzysztof\Desktop\[ZSTANMAGS 25012021.xls]Arkusz1'!$M$1:$P$65536;2;0);0)


MAm wiele komórek, w których w formułach odwołuję się do adresu

Kod:
'C:\Users\Krzysztof\Desktop\[ZSTANMAGS 25012021.xls]Arkusz1'


JAk zapisać ten adres w taki sposób w jednej komórce, by po jego podmianie aktualizowały się wartości wszystkich komórek, w których używam formuł zawierających ten adres?

JAkiej być może uzyć formuły pośredniej? Czy ma tu zastosowanie adr.pośr.?

Celem jest jak łatwo się domyśleć eliminacja aktualizacji formuł poprzez ich kopiowanie.
Docelowym modelem jest aktualizacja adresu w jednej komórce, bo której wszystkie formuły mają się same aktualizowa


Prośba o pomoc
_________________
Uneasy
ID posta: 399941 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 470 razy
Posty: 1456
Wysłany: 08-02-2021, 09:10   Re: Adres do innego pliku jako zmienna w formule wyszukiwani

Uneasy napisał/a:

JAkiej być może uzyć formuły pośredniej? Czy ma tu zastosowanie adr.pośr.?

Tak.
Pamiętaj, że ona działa tylko wtedy gdy plik do którego się odwołuje jest otwarty.
_________________
Pozdrawiam
xFish
ID posta: 399947 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 2111 razy
Posty: 6618
Wysłany: 08-02-2021, 11:43   

Inny sposób to użycie nazwy np. tablica. Wywołanie wygląda tak:
Kod:
=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(A1;tablica;2;FAŁSZ);"")
A nazwa tablica jest zdefiniowana w Menedżerze nazw i może odnosić się do zamkniętego skoroszytu, np.
Kod:
='C:\Users\gonet\Documents\Excel_pliki\[src1.xlsx]Arkusz1'!$E$4:$F$7
Nazwę tę można wyedytować w Menedżerze nazw i zmienić nazwę pliku np. z src1 na src2.
Oczywiście wygodniej jest tworzyć nazwę przez wskazanie zakresu przy otwartym pliku, a potem dopiero go zamknąć. Ścieżka dopisze się sama.

Wyszukaj_w_tablicy.zip
Pobierz Plik ściągnięto 1 raz(y) 18.06 KB

ID posta: 399960 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe