Pełna wersja: Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ
forum użytkowników Excela - makra, formuły, VBA, funkcje - porady, Excel
 
lo - fi version Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ index

funkcja jeżeli test logiczny
Kliknij tutaj aby przejśc do pełnej wersji tematu

 
       Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ Strona Główna -> Mam problem z formułą
Poprzedni temat :: Następny temat  
Elkom Wysłany: 28-03-2013, 08:42  

Dzień dobry, chce wprowadzić funkcje jeżeli. W teście logicznym chce wprowadzić podwójna nierówność y<=x<=z, jeśli x spełnia podwójną nierówność to chciałabym aby pojawił sie znak "+" a jeśli x nie spełnia owej nierówności to znak "-" . Staram się ale nie wiem jak uwzględnić to w teście logicznym. Prosze o pomoc.
marzatela Wysłany: 28-03-2013, 08:53  

Formuła:
Kod: =JEŻELI(ORAZ(x>=y;x<=z);"+";"-")
kuma Wysłany: 28-03-2013, 08:54  

Witaj. Można napisać taką formułę:
Kod: =JEŻELI(ORAZ(x>=y;x<=z);"+";"-")
Pozdrawiam.
Elkom Wysłany: 28-03-2013, 09:16  

dziekuje serdecznie, działa, chciałabym aby pola ze znakiem plus były brane do dalszych obliczeń a pola ze znakiem minus nie, i nie wiem jak mam to uwzględnic w dalszych obliczeniach formułe mam wpisaną ale trzeba ją rozszerzyc o funkcje jeżeli w kolumnie wynik badania, proszę o pomoc.
marzatela Wysłany: 28-03-2013, 09:52  

A napisz to jakoś po ludzku. Masz komórki, w których w wyniku działania funkcji jest znak + lub - . Jest to konkretna wartość tekstowa. Wynik badania co oblicza? O co chcesz rozszerzyć funkcję?
Elkom Wysłany: 28-03-2013, 10:08  

znaki + oraz - oceniają wartości w komórkach sąsiednich, które mają być brane do dalszych obliczeń. Chodzi o to tylko te wartości w komórkach sąsiednich ocenione jako + były brane do obliczeń. Wynik badania oblicza ilość zuzytego tlenu. Formuła na ilość zużytego tlenu jest wprowadzona tylko trzeba ją rozszerzyć aby uwzględniała tylko wartości cenione jako + .
marzatela Wysłany: 28-03-2013, 10:29  

No fajnie, ale jak ta formuła wygląda? Trudno rozszerzyć coś, czego się nie widzi. Najprostsza formuła sprawdzająca, jaki jest wynik wygląda tak:
Kod: =JEŻELI(X="+";"bierz do obliczeń";"nie bierz")
W miejsce "bierz/nie bierz do obliczeń możesz wstawić swoją funkcję.
Elkom Wysłany: 28-03-2013, 10:44  

dołączyłam plik do 1 postu, na czerwono zazanczyłam komórki które mnie interesuja w tej kwestii.

[ Dodano: 2013-03-28, 10:46 ]
wpisałam tak jak mówisz i nie chce mi rozwiązać formuły tylko ją wyswietla.

[ Dodano: 2013-03-28, 10:52 ]
wpisałam tak Kod: =Jeżeli(X="+";"F2-((C2-B2)/C2)*L2)*(C2/B2)";"NIE BIERZ" zamiast obliczyc wartość frmuły to poprostu ją wyświetla
Kapol Wysłany: 28-03-2013, 10:57  

W cudzysłów bierzemy wartości tekstowe, formuły wpisujemy bez.
Elkom Wysłany: 28-03-2013, 11:05  

pozbyłam sie " " i teraz wyskoczył błąd... na czarno zaznacza "nie bierz"
Zmora Wysłany: 28-03-2013, 11:10  

A nie tak?

Kod: =JEŻELI(G2="+";((F2-(C2-B2)/C2)*L2)*(C2/B2);"NIE BIERZ")
Elkom Wysłany: 28-03-2013, 11:17  

teraz pojawił mi się inny wynik, cos z nawiasami jest pokręcone wynik powinien wyjśc 90,99... pozbyłam się "nie bierz" i przelicza wartości tam gdzie komórka oceniona jest na +, a tam gdzie jest - wynik jest =0... może tak zostać, dziękuje za wskzówki, pozdrawiam
Zmora Wysłany: 28-03-2013, 11:19  

Kod: =jeżeli(G2="+";(F2-(C2-B2)/C2*L2)*C2/B2;"NIE BIERZ")
Elkom Wysłany: 28-03-2013, 11:24  

Extra działa, jestem bardzo wdzięczna, jednak problem tkwił w nawiasach, Pozdrawiam
 
       Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ Strona Główna -> Mam problem z formułą
Strona 1 z 1

To jest wersja lo-fi głównej zawartości. Aby zobaczyć pełną wersję z większą zawartością, obrazkami i formatowaniem proszę kliknij tutaj.



Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.