Pełna wersja: Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ
forum użytkowników Excela - makra, formuły, VBA, funkcje - porady, Excel
 
lo - fi version Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ index

27. Funkcja suma.jeżeli/licz.jeżeli dla 2 i więcej warunków
Kliknij tutaj aby przejśc do pełnej wersji tematu

 
       Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ Strona Główna -> FAQ - Najczęściej zadawane pytania
Poprzedni temat :: Następny temat  
zielony Wysłany: 29-10-2007, 16:43  

W związku z powtarzającymi się tematami na forum odnośnie wykorzystania funkcji licz.jeżeli, bądź suma.jeżeli przy spełnieniu więcej niż jednego warunku załączam przykładowy plik rozwiązania tego problemu

Wykorzystano:
SUMA.ILOCZYNÓW

edit Kaper: użytkownicy Excela 2007 i nowszych powinni zacząć od zapoznania się z funkcjami SUMA.WARUNKÓW i LICZ.WARUNKI - przykład niżej: http://www.excelforum.pl/...3582.htm#138303
zielony Wysłany: 05-11-2007, 11:55  

Mozliwe przyczyny bledow:

Blad #N/D!
- Moglo nastapic zaznaczenie zakresow o roznej wielkosci

Blad #LICZBA!
- Formula zwraca taki blad w przypadku zaznaczenia jako zakresu calej kolumny - wystarczy zmniejszyc zakres choc o 1 komorke

Formula zwraca nieprawidlowa wartosc
- Mozliwe sa drobne, niezauwazalne roznice w tekscie, a dla formuly wartosci "A" oraz "A " sa czym innym
- Liczba nie zostanie znaleziona, w przypadku gdy bedzie przechowywana w arkuszu jako tekst

Jak znajde kolejne opcje, to dopisze
Piotr_Korbicz Wysłany: 02-02-2009, 20:00  

Jakoś nie przekonałem się nigdy do SUMA.ILOCZYNÓW stąd w załączniku te same obliczenia wykonane funkcją SUMA
Dodatkowo w załączniku składnie umożliwiające łączenie warunków ORAZ i LUB.
sales Wysłany: 03-02-2009, 07:31  

Idąc za ciosem. Dalszy ciąg zastosowania funkcji SUMA.
Bardzo często spotykam się z sumowaniem wartości z parzystych lub nieparzystych wierszy.
Dodatkowym utrudnieniem jest występowanie wartości liczbowych na przemian z tekstem.
Wormsek Wysłany: 06-11-2009, 08:26  

Hmm a ja mam zapytanie do tego punktu.

Czym różnią się te 3 zapisy w działaniu? :> Bo wynik jest taki sam. :hamer

Kod: =SUMA.ILOCZYNÓW(($N$7:$N$14=111)*($O$7:$O$14=2)*($P$7:$P$14))

=SUMA.ILOCZYNÓW(($G$7:$G$14=111)*($H$7:$H$14=2);$I$7:$I$14)

{=SUMA(($G$7:$G$14=111)*($H$7:$H$14=2)*($I$7:$I$14))}
bodek Wysłany: 06-11-2009, 14:41  

Wormsek napisał/a: Czym różnią się te 3 zapisy w działaniu? :> Bo wynik jest taki sam Jakby to napisać :-/ , skoro wynik taki sam, to w efekcie końcowym niczym.
SUMA.ILOCZYNÓW() - funkcja arkuszowa służąca do przemnażania danych w zakresach (tablicach) o identycznym rozmiarze, podawanych kolejno jako argumenty tej funkcji (oddzielone poprzez średnik) i podsumowująca elementy końcowej tablicy będącej wynikiem mnożenia pierwotnych.
Ale jako pojedynczy argument funkcji możesz podać nie tylko samą tablicę z zakresem komórek, ale również formułę, która zwróci tablicę, albo działanie na tablicach, które zwróci tablicę itd. Pierwszy Twój zapis to właśnie taki przykład, funkcja ma jeden argumnet.
Drugi zapis, pierwszy arg. to działania na tablicach zwracające tablicę, drugi to sama tablica (zakres kom).

Trzeci przykład, to oczywiście już formuła tablicowa, która również realizuje te same zadanie, czyli mnoży tablice, na koniec funkcja SUMA() sumuje wyniki z tablicy końcowej.
Podobno SUMA.ILOCZYNÓW() jest szybsza od f.tablicowych, ale dla normalnej ilości danych jest to bez znaczenia.

Proponuję testy jak każda w/w formuła liczy: pasek Inspekcja formuł -> przycisk "szacuj formułę".
Demonides Wysłany: 31-07-2010, 09:07  

Dorzucam jeszcze arkusz korzystający z funkcji suma.jeżeli zliczający dane spełniające 2, 3 i 4 kryteria. Tym sposobem można zliczać dane spełniające max 6 kryteriów.

Pzdr
tkuchta1 Wysłany: 31-07-2010, 10:50  

ilość warunków uzależniasz od ilości możliwych zagnieżdżeń f. JEŻELI. ALe przecież można nie zagnieżdżać - nie :-)
tablicowo Kod: =SUMA(JEŻELI(($B$2:$B$28="krzesło")*($D$2:$D$28=1998)*($C$2:$C$28="biały")*($A$2:$A$28=1);$E$2:$E$28;0)) albo zupełnie pominąć f.JEŻELI Kod: =SUMA(($B$2:$B$28="krzesło")*($D$2:$D$28=1998)*($C$2:$C$28="biały")*($A$2:$A$28=1)*($E$2:$E$28))
Kaper Wysłany: 24-11-2011, 15:29  

Excel 2007 i 2010 zaczynają być popularniejsze niż poprzednie wersje, więc chyba czas w tym miejscu zwrócić uwagę na dwie spośród funkcji dodanych do wersji 2007:
SUMA.WARUNKÓW i LICZ.WARUNKI

Korzystając z SUMY.WARUNKÓW osoby przyzwyczajone do SUMY.JEŻELI powinny zwrócić uwagę na inną kolejność argumentów.

Przykład zastosowania SUMY.WARUNKÓW dla danych z poprzedniego wpisu w załączniku.

Pozdrawiam,
 
       Excel Forum - Porady, Pomoc, Excel Help, Excel FAQ Strona Główna -> FAQ - Najczęściej zadawane pytania
Strona 1 z 1

To jest wersja lo-fi głównej zawartości. Aby zobaczyć pełną wersję z większą zawartością, obrazkami i formatowaniem proszę kliknij tutaj.



Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.